UMEC Forum Index UMEC
United Mining Exploration Commission: A group of friends playing JumpGate-- "a MMORPG that launched smoothly, breaks from fantasy character setting, emphasizes PvP, and is the first persistent world space simulator that nobody talks about." ~Scorch
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Joystick subthread (throttle map probs)

 
Post new topic   Reply to topic    UMEC Forum Index -> Free Database (JumpGate)
View previous topic :: View next topic  
Author Message
MajorFreak
Guest





PostPosted: Wed Dec 18, 2002 1:53 am    Post subject: Joystick subthread (throttle map probs) Reply with quote

Thorshmr wrote:
Heeeelllllpppp!!!
Lol....well, I got this new fancy-dancy Saitek X45 joystick/throttle....but I'm having a bit of trouble getting it set up.

If anyone uses one could you please lend me a hand?

The problem I'm having is that the throttle won't work. When I'm in the calibration screen in the Saitek software, it recognizes the throttle just fine. When I set the throttle in Jumpgates controls config screen that recognizes the throttle just fine.

But when I launch I have no throttle control at all. If I leave the game on a default joystick config it sets the throttle to the lower of the two rotary switches on the throttle handle, but not the throttle axis itself.

Right now, not being familiar with the setting up of profiles in the Saitek software, I just created a "new" profile and just renamed and saved it....with no actual tailoring of the button functions.

If anyone has advice on how I can get it to work or if they have a working profile they can send me the help would be greatly appreciated. Until then I'm grounded unless I want to go back to my Precision stick and put this $80 wonder on the shelf

Thanks, guys & gals, in advance for any and all help
Veloxi wrote:
I'm using the Saitek X-36, the predecessor to the X-45, and throttle works beautifully. You simply have to go into the options screen and bind it to the throttle control to the throttle axis.

I'm currently using the latest saitek drivers on Win XP Pro, and have had no problems. All of my axis, from the throttle to the rudder, work like a champ. Also, don't use any profiles, just keep it cleared of profiles when using JG. If you have any further questions, please don't hesitate to ask.
Excelsior wrote:
My throttle works fine in XP. But I use the Dhauzimmer drivers along with the GREAT HazardScript. But I load a basic DX setup for Jumpgate.

Dhauzimmer's version is 2.105; HazardScript is 2.605; http://saitekhelp.simhq.com
Anguish wrote:
Just thought I'd add on for anyone else having throttle problems with JG. There's a strange bug where the game will accept your axis as the control, but not actually use it in game. Unfortunately, the only known way to deal with that is to literally try, try again. Upwards of two dozen attempts at setting throttle to your throttle control, or keyboard input is sometimes required. I've only heard of people having this issue with standalone throttles, as opposed to built-in controls on existing joysticks, but it may apply to both. Just keep trying. It can, and will eventually work.
nanotech wrote:
Another (slightly faster) fix I've heard of and seen used is to map your throttle to your rudder and vice-versa. Launch into the sim, dock (if you can), then map them back to where they're supposed to be and all is well.

I had to do it and it worked. (also had a blast trying to dock using my rudder for throttle and centering the throttle so I didn't roll all day long)
Excelsior wrote:

http://www.theddz.com/excelsior/jgbuttonsx45.jpg
Back to top
MajorFreak
Guest





PostPosted: Tue Dec 31, 2002 8:31 am    Post subject: Reply with quote

Marquis wrote:
Along the same lines here, I just got a Cyborg 3D Gold and the throttle will NOT work in game even after I tried all of the stuff suggested above and a half dozen other little things besides. Anyone have any more ideas?

I'm assuming he didn't understand the multiple/conflicting instructions...hopefully he's not cluerepellant AND we get a fresh response that i can add.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    UMEC Forum Index -> Free Database (JumpGate) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Space Pilot 3K template by Jakob Persson.
Powered by phpBB © 2001 phpBB Group